Advance Imaginations

It's All About (The) Advance Imaginations.

Monday, January 2, 2023

Conditionals and Loops - For Loop in C - HackerRank Solutions

 Objective

In this challenge, you will learn the usage of the for loop, which is a programming language statement which allows code to be executed until a terminal condition is met. They can even repeat forever if the terminal condition is never met.

The syntax for the for loop is:

for ( <expression_1> ; <expression_2> ; <expression_3> )
    <statement>
  • expression_1 is used for initializing variables which are generally used for controlling the terminating flag for the loop.
  • expression_2 is used to check for the terminating condition. If this evaluates to false, then the loop is terminated.
  • expression_3 is generally used to update the flags/variables.

The following loop initializes to 0, tests that is less than 10, and increments at every iteration. It will execute 10 times.

for(int i = 0; i < 10; i++) {
    ...
}

Task

For each integer  in the interval  (given as input) :

  • If , then print the English representation of it in lowercase. That is "one" for , "two" for , and so on.
  • Else if  and it is an even number, then print "even".
  • Else if  and it is an odd number, then print "odd".

Input Format

The first line contains an integer, .
The seond line contains an integer, .

Constraints

Output Format

Print the appropriate English representation,even, or odd, based on the conditions described in the 'task' section.

Note: 

Sample Input

8
11

Sample Output

eight
nine
even
odd

CODE

      

#include<stdio.h>
void convert_num_to_letter(int no){
  switch (no)
  {
  case 1:
    printf("one");
    break;
  case 2:
    printf("two");
    break;
  case 3:
    printf("three");
    break;
  case 4:
    printf("four");
    break;
  case 5:
    printf("five");
    break;
  case 6:
    printf("six");
    break;
  case 7:
    printf("seven");
    break;
  case 8:
    printf("eight");
    break;
  case 9:
    printf("nine");
    break;
  }
}
int main(){
  int lower, upper, i;
  scanf("%d\n%d",&lower,&upper);

  for(i =lower;i<=upper; i++)
  {
    if(i <= 9 && i >= 1){
      convert_num_to_letter(i);
      printf("\n");
    }
    else if(i>9 && (i%2==0)){
      printf("even\n");
    }
    else if(i>9 && i%2 != 0){
      printf("odd\n");
    }
  }

  return 0;
}

       



No comments:

Post a Comment

Thanks for spending some time with our blogs; we value your time & feedback. It motivates us to create even more meaningful content further.